Como instalar Stata 12 en Ubuntu Linux 12.04 (también en Elementary OS)

Hola gente, ^_^

Me decidí (sabiendo que iba a salir laaaargo) a escribir un lindo post para explicar en un paso a paso cómo instalar Stata 12 en Ubuntu 12.04, Ubuntu 12.10, y Ubuntu 13.04 (32bits o 64bits). Stata 12 es un programa de estadísiticas y econometría utilizado por gran parte de los economistas de ahora (ejem) y también por otros científicos, como biólogos, ingenieros, sociólogos… etc. Este post sirve perfectamente para Elementary OS Luna, así como para Linux Mint y otros derivados de Ubuntu (y, quizás, para debian también sirva, ni idea… :P).

Todo lo que hago lo saqué de la red, pero el asunto es que está todo disperso, tuve que probar varias veces antes de tener éxito, y al final terminé con mi sistema todo agujereado. Funcional, pero agujereado. Luego de décadas de desarrollo (ueeeeeh) pulí un poco toda la data que tenía probando de a poco y resulta que la instalación es bastante sencilla. Sólo que uso algunos los “truquitos” para que todo funcione a la perfección. Ahí va.

Captura de pantalla de 2013-06-05 09:03:48

Instalando Stata 12 en Ubuntu (versión ONE STEP, para usuarios que la tienen clara… o para los que  quieren no leerme más jeje)

Parados en la dirección en donde están los instaladores, ejecutar esto: (OJO reemplazar rho:rho por su nombre de usuario y grupo!)

sudo apt-get install libgtksourceview-3.0-common libgtksourceview2.0-0 libgnomeprint2.2-0 alacarte -y && sudo ln -s /usr/lib/libgtksourceview-2.0.so.0 /usr/lib/libgtksourceview-1.0.so.0 && sudo ln -s /usr/lib/x86_64-linux-gnu/libtiff.so.4.3.4 /usr/lib/libtiff.so.3 && sudo mkdir /usr/local/stata12/ && sudo chown rho:rho /usr/local/stata12/ && sudo cp * /usr/local/stata12/ && cd /usr/local/stata12/ && sudo chown -R rho:rho /usr/local/stata12/ && tar -xzvf docs.taz && tar -xzvf base.taz && tar -xzvf bins.taz && tar -xzvf ado.taz && chmod -R 755 .

Crean un “launcher” al archivo xstata o directamente parados en /usr/local/stata12/ ejecutar ./xstata desde una terminal. Tadaaa. :)

Si tienen dudas… problemas… o quieren saber los pormenores… pos sigan leyendo. :P

—digamos que el post en serio empieza acá, pero como me quedó muy largo decidí hacer la versión corta de arriba—

^_^

(Recomenzando civilizadamente) Un poco de background: qué cazzo es stata?

Para los que no lo conocen, Stata 12 es un software de estadística, y es realmente el estándar en econometría y manejo de datos en economía (segundeado por otro “más light” del palo, que se llama SPSS… oootro cuento). Este software, como tantos otros, tiene un competidor potentísimo en el mundo open-source que se llama R, pero ese también es cuento para otro momento. Lo que quería decir es que Stata no es open-source, ni tampoco gratis, por lo que en realidad me rompe bastante las bolas tener que estar -casi- obligado a usarlo. A pesar de esto, está claro que es un software potentísimo.

Captura de pantalla de 2013-06-04 21:04:34

No todo es marrón en la vida, y la buena noticia es que funciona PERFECTO en Ubuntu, de hecho, creo que funca mejor que en win-máaatenme-dows. Una ventaja evidente es que  “Stata 12 for Linux” tiene dos clientes: xstata, que es la versión normal que uno esperaría encontrar, que es igualita a la que todos conocemos corriendo en “la compe”; y una versión exclusiva para Unix sin interfaz gráfica, es decir, un cliente puro de terminal. Este cliente hace que el programa no tenga que dibujar las ventanitas ni nada de la interface (a.k.a GUI), por lo que prescinde de cargar un montón de librerías, ahorrando mucha mucha memoria…  Literalmente le saca el juguito a la compu en donde lo corras.

Captura de pantalla de 2013-06-05 09:08:57

(Stata y .do files editor en Ubuntu)

Seguro algún día me meto un poco más con los temitas de arriba, del open-source y todo eso…  pero ahora manos a la obra: a instalar el bastardo.

Instalando Stata 12 en Ubuntu (versión explicada)

Paso 1) Tenés Stata no?

Primero, vamos a necesitar un Stata no? ja. Lo pueden comprar acá http://www.stata.com/stata12/ jaja.

Captura de pantalla de 2013-06-04 21:17:29

O pueden explorar algunas alternativas diferentes y conseguir Stata por su cuenta, con alguna ayuda de sus amigos (oooh) ;P

Captura de pantalla de 2013-06-04 20:37:47

Paso 2) Instalando dependencias y preparando librerías.

Ok, entonces digamos que tenemos Stata. Me voy a basar, de acá en adelante, en las instrucciones para un Ubuntu 12.04 de 64bits. Pero es exactamente lo mismo para un entorno de 32 bits, con la obvia excepción de que tienen que ejecutar otros instaladores (los de 32bits). :)

Bueno, lo primero que hay que hacer, es abrir una terminal, y luego ir a donde tengamos los archivos para instalar stata. En mi caso:

cd /home/rho/Dropbox/instaladores/Software/stata-12-linux/linux.64.installer/

Los archivos instaladores están en las carpetas de 32 o 64 bits, y su contenido es este que se ve en la pantalla. Es importante que desde la terminal estemos parados en esta locación.

Captura de pantalla de 2013-06-04 21:20:20

Luego hay que instalar las siguientes dependencias:

sudo apt-get install libgtksourceview-3.0-common libgtksourceview2.0-0 libgnomeprint2.2-0 alacarte -y

y hacer un par de magias creando enlaces virtuales entre las librerías para que no tire errores de que no quiere arrancar (de hecho este es un punto clave de la instalación para que funcione la interfaz gráfica). Vinculamos dos librerías con lo que se llama un enlace simbólico (comando ln -s), de forma que una librería refiera a la otra cuando el programa la llama… En fin, para seguir, peguen esto en la terminal, jaja.

sudo ln -s /usr/lib/libgtksourceview-2.0.so.0 /usr/lib/libgtksourceview-1.0.so.0 && sudo ln -s /usr/lib/x86_64-linux-gnu/libtiff.so.4.3.4 /usr/lib/libtiff.so.3

Con esto terminamos la segunda parte. Ahora vamos a los postres.

Parte 3: Instalando al madafaka

Bien, resumidamente, lo que tenemos que hacer es crear el directorio en donde se instalará Stata, descomprimir y mover los instaladores, arreglar los permisos de escritura y ejecución y ya estamos.

Creamos el directorio de instalación con el siguiente comando (requiere sudo, así a meter la password):

sudo mkdir /usr/local/stata12/

Ahora hay que empezar con el asunto de los permisos. Hay que cambiar los permisos de la carpeta que acabamos de crear para que sea del nivel de usuario. La razón de esto es que querríamos ejecutar stata a nivel de usuario, y no tener que meter una password de super-user (sudo) cada vez que corremos el programa (con los 1800 problemas que eso llevaría). Para eso vamos a usar el comando chown, que tendremos que completar con nuestro nombre de usuario y grupo. Si no saben mucho de linux, a esta altura deben estar puteandome. jaja. Pero bue, es así muchachos. En general la cosa es “tunombredeusuario:tunombredeusuario” a pesar de que la primera parte antes de los dos puntos es el nombre de usuario y la otra es el grupo. Más info sobre esto acá. Dicho todo esto, seguimos con el asunto cambiando los permisos de carpeta:

sudo chown rho:rho /usr/local/stata12/

Como decía, la parte de rho:rho deberían cambiarla por su propio nombre de usuario. Si su username es “pepito”, reemplazan por pepito:pepito.

Ahora estamos casi ahí. Copiamos todo y cambiamos permisos de nuevo:

sudo cp * /usr/local/stata12/ && cd /usr/local/stata12/ && sudo chown -R rho:rho /usr/local/stata12/

Descomprimimos toda la gilada, y yastá.

tar -xzvf docs.taz && tar -xzvf base.taz && tar -xzvf bins.taz && tar -xzvf ado.taz && chmod -R 755 .

(ojo, el punto del final no es un error)

Ahora oficialmente stata está instalado. Para terminar el trabajo prolijamente, podemos armar un “atajo” al menú para ejecutarlo directamente como a cualquier otro programa.

Paso 4) Creando un launcher

Bueno, esta parte es la más simple. De hecho hasta algunos podrían pensar innecesaria. Stata se puede ejecutar desde una terminal escribiendo

cd /usr/local/stata12/ && ./xstata

Pero la verdad es que es más cómodo tener una aplicación con un launcher y un ícono, que es algo un poco más normal. El proceso es bastante simple, tenemos que instalar el programita para editar los menues (alacarte) y luego crear el atajo. En una terminal, ponemos

sudo apt-get install alacarte -y

alacarte

(armando el launcher)

Después ejecutamos alacarte desde el menú, o como quieran, incluso tipeando en la terminal… creamos un nuevo elemento (dentro de oficina o en la categoría que les guste) y ponemos, como está en la imagen, el nombre del launcher, en mi caso se llama “Stata 12 for Linux 64bits” (pero pueden poner lo que quieran) y luego ingresasn en el campo del comando (este si es importante) /usr/local/stata12/xstata (también podemos configurar el ícono, que está en el mismo directorio /usr/local/stata12/).

Ahora si, listo. Cuando ejecutemos el programa el ícono se va a ver así en el dock, y también podremos agregar fácilmente un “atajo” encastrando el botón ahí mismo (este proceso es diferente dependiendo del dock que usen -en mi caso es awn-).

stataicon

Ahora haciendo click sobre el ícono se abre stata y se ve así:

(Pantalla principal Stata 12)

Captura de pantalla de 2013-06-04 20:10:58

(Graph Editor -centro- y menu de open-file -izquierda- y do editor en Stata 12 for Linux)

Captura de pantalla de 2013-06-05 09:11:07

Espero le sirva a alguien,

Salú!

Rho

Como instalar Stata 12 en Ubuntu Linux 12.04 (también en Elementary OS)

78 thoughts on “Como instalar Stata 12 en Ubuntu Linux 12.04 (también en Elementary OS)

  1. Nico Chavez says:

    Disculpa, pude intalar stata, pero cuando tratato de arrancarlo me dice que no encuentra stata.lic, como hiciste con el tema de la licencia, porque yo tengo un serial, pero no se como agregar la licencia. Gracias

    1. hola, cómo va. Qué raro, porque en general en los paquetes torrent está la licencia. Tenés que conseguirte una, hay muchas por ahí. Por ejemplo en el pack torrent del post, podés bajarte sólo el archivo de la licencia sin tener que bajar todo. Una vez que tenés la stata.lic, la tenés que copiar en /usr/local/stata12 y listo. :)
      Gracias por pasar y preguntar, y cualquier cosa decime que no hay problema.

  2. Nico Chavez says:

    No se porque, pero no me funciona el link de la pagina… sabes de otro lugar donde pueda descargar la licencia o podrás copiar la tuya. Gracias

  3. Micktlanteka says:

    Gracias Rho, hace falta más gente buena como tú para que nosotros los neofitos de linux apréndamos algo… Saludos

    1. Hey! muchas gracias por la buena onda :)

      Todos arrancamos así, es simplemente pasar la posta. ^_^

      Muchas gracias por pasar y pasate nomás que todas las semanas pongo alguito nuevo jeje.

      Un abrazo!

    1. Hey. No problem, tell me please what you did, so I’ll be able to help you properly. However the steps are pretty simple.
      You have to paste the content of the stuff on github in you home folder, in this address:
      ~/.config/sublime-text-3/Packages/User/
      …probably this step by step line help you (if not, just copy-paste it and see if it’s working):

      wget https://github.com/rpowers/sublime_stata/archive/master.zip && unzip master.zip && rm master.zip && cd ~/sublime_stata-master/Stata/ && mkdir -p ~/.config/sublime-text-3/Packages/User/Stata/ && cp *.* ~/.config/sublime-text-3/Packages/User/Stata/ && cd ~ && rm -R ~/sublime_stata-master && sudo ln -s /usr/local/stata12/xstata /usr/bin/xstata

      I’ll try to do a post on this as soon as I find a couple of hours :)

      1. rdk says:

        Thanks for reply. Managed to sort out the problem. Files from github had to be placed in /opt/sublime_text/Packages. Had to zip the folder and rename to Stata.sublime-package. Then all works fine =)

    1. Hah. that’s tricky. Theoretically YES, but… I don’t know how to do it. This guy https://github.com/rpowers/sublime_stata made the tweek that I translated to linux, however the selective part is different cause he’s using some mac commands to paste-selection-to-temp-file that I don’t know how to apply on Ubuntu.
      After trying and reading a bit I surrendered. :P But it’s totally possible… the trick is to be able to write that temp file filled with the “current text selection”. Then, the execution should be similar to the process used in the general .do files.
      Let me know if you find something! :)

  4. Ale says:

    Por favor necesito tu ayuda para instalar STATA… soy nueva en Ubuntu y no tengo idea de utilizar estos comandos… por fa…no quiero cambiarme a Windows solo por culpa del Stata

    1. Hola Ale, los comandos los tenés que copiar en una terminal.
      Terminal es una app que encontrás aprentando el botón de ubuntu y escribiendo “terminal”, sin comillas, y luego dando enter.
      Acordate que te tenés que bajar la versión de stata que es para Linux! :)
      Cualquier cosa, escribime por acá. :)

    1. Hola Joao, la verdad, ni idea. Creo que los paquetes de dependencias deberían tener más o menos el mismo nombre. El resto del proceso es similar. Pero no uso Arch desde hace muchos años y la verdad es que tampoco me atrevería a decirte cómo se hace específicamente en esa distro porque no la conozco bien. :) Sorry que no te pueda ayudar más.

      1. Rayos!. He logrado instalarlo satisfactoriamente es Kubuntu, pero por más que trato de instalarlo en Chakra, no puedo (te pregunté por Arch porque Chakra es una derivada). Sin embargo al compilar las librerías con el comando “ccr -S” (si no me equivoco es para que accede a los repositorios AUR de Arch) me da error. Te copio un fragmento del log, porsiacaso tuvieras la solución, por más que he googleado no encuentro la respuesta en ningún lado.

        ” gcc -DHAVE_CONFIG_H -I. -I.. -I.. -I.. -Wall -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DDATADIR=\”/usr/share\” -march=x86-64 -mtune=generic -O2 -pipe -MT gnome-cups-i18n.lo -MD -MP -MF .deps/gnome-cups-i18n.Tpo -c gnome-cups-i18n.c -fPIC -DPIC -o .libs/gnome-cups-i18n.o
        In file included from gnome-cups-i18n.c:2:0:
        /usr/include/glib-2.0/glib/gmacros.h:32:2: error: #error “Only can be included directly.”
        #error “Only can be included directly.”
        ^
        make[2]: *** [gnome-cups-i18n.lo] Error 1
        make[2]: se sale del directorio `/tmp/ccrbuild-1000/libgnomecups/libgnomecups/src/libgnomecups-0.2.3/libgnomecups’
        make[1]: *** [all-recursive] Error 1
        make[1]: se sale del directorio `/tmp/ccrbuild-1000/libgnomecups/libgnomecups/src/libgnomecups-0.2.3′
        make: *** [all] Error 2
        ==> ERROR: Se produjo un error en build().
        Cancelando…
        The build failed.
        Dependencies for `libgnomeprint’ are not met, not building…”

        No te copio todo el log, porque es extenso jajaja, sólo el fragmento del error. Me he enamorado de Chakra, no quisiera tener que cambiarlo por este programa, que es de uso obligatorio, ni tampoco quisiera tener que emularlo en virtualbox. Chakra es una distribución hermosa, KDE en su estilo más puro. Te amaré eternamente si me das solución.

      2. Hola Joao! Jajaja… ERA CHAKRAAAA!!! ahora si. Entiendo todo. : )
        Estuve tratando de hacer correr stata en chakra por 2 semanas. Jeje. Sencillamente no pude. :P
        El problema son las dependencias gtk que están adrede bloqueadas para que no se puedan instalar (porque la propuesta de la distro es esta idea de sólo kde, nada gtk). Dado que stata -y otros programas- fueron desarrollados en gtk, la posibilidad de hacerlos correr en chakra es muy remota y, de poderse hacer, requiere compilar desde la fuente (a lo gentoo) un MONTÓN de librerías. El punto es que si se instalan esas librerías, entonces la propuesta de usar chakra deja de tener sentido porque ya no sería una distro sólo kde… Anyway. Poder, no pude. Teóricamente, se puede… pero requiere ser master jedi en compilación y tener muuuucho tiempo. Hay que forzar a la distro a compilar las librerías gtk de gnome. El resultado será que seguramente stata funcione, de funcionar, como el ojete :P
        Nada, todo muy lindo con chakra pero kde no pudo satisfaser mis necesidades de programas, así que chau, quedó en una laptop de por ahí.
        Volviendo a tu error particular, libgnomecups se podría instalar manualmente, pero el problema es que depende de una cantidad librerías más heavys que se tendrían que compilar manualmente.
        Sorry… pero me pa que es una misión entre sin sentido e imposible, :)

      3. Oh!, qué mala suerte. Suena desafiante, pero a la vez pesado. No creo que funcione como el ojete, pues Chakra instala las librerías GTK en un lugar apartado para que no “contamine” el sistema. Tengo aplicaciones gtk como Mozilla y Gimp, y corren exactamente igual que en cualquier otra distribución. Al menos eso espero, que sea totalmente fluido. Te comento mis resultados. Quizás no tenga sentido, pero la curiosidad puede más jaja. Gracias de todas maneras por tu ayuda estimado Rho.

      4. Seee… se del soporte gtk de chakra. Usé la distro por dos releases y más o menos entré en contacto con la lógica. Sin embargo ojo!, no te confundas porque el soporte para firefox y gimp se hace en especies de “bottles” a la Crossover o Wine. Esto quiere decir que cada bottle tiene que ser construida con un conjunto de librerías específico. Igualmente cre que debería ser posible instalar “de prepo” todas las librerías que se requieren para un uso básico de stata… pero posible no quiere decir ni práctico ni fácil… : )
        Te comento que en entornos gnome funciona de mil maravillas. Hice una clean install y me abre más rápido que gedit :P jeje.

  5. Dylan says:

    sudo ln -s /usr/lib/libgtksourceview-2.0.so.0 /usr/lib/libgtksourceview-1.0.so.0 && sudo ln -s /usr/lib/x86_64-linux-gnu/libtiff.so.4.3.4 /usr/lib/libtiff.so.3

    Este paso no me funciona me sale (ln: opcion incorrecta —
    Que hacer Soy nuevo en este mundo de linux

    1. Hola Dylan, primero, asegurate que haya corrido el paso anterior en una terminal:
      sudo apt-get install libgtksourceview-3.0-common libgtksourceview2.0-0 libgnomeprint2.2-0 alacarte -y
      Luego volvelo a correr. Tendría que andar. Si no te anda te pido de favor que me pegues el output que te da la terminal y que me digas qué distribución de linux estás usando.

      Saludos y no te preocupes que lo hacemos andar de una :)

      1. Dylan says:

        $ sudo apt-get install libgtksourceview-3.0-common libgtksourceview2.0-0 libgnomeprint2.2-0 alacarte -y
        y esto me responde :

        Leyendo lista de paquetes… Hecho
        Creando árbol de dependencias
        Leyendo la información de estado… Hecho
        libgtksourceview-3.0-common ya está en su versión más reciente.
        alacarte ya está en su versión más reciente.
        libgnomeprint2.2-0 ya está en su versión más reciente.
        libgtksourceview2.0-0 ya está en su versión más reciente.
        Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
        hyphen-en-us mythes-en-au openoffice.org-hyphenation
        Use ‘apt-get autoremove’ to remove them.
        0 actualizados, 0 se instalarán, 0 para eliminar y 141 no actualizados.

        Luego pongo:
        $ sudo ln -s /usr/lib/libgtksourceview-2.0.so.0 /usr/lib/libgtksourceview-1.0.so.0ln: fallo al crear el enlace simbólico «/usr/lib/libgtksourceview-1.0.so.0»: El archivo ya existe

        Gracias de antemano!!

  6. mikel says:

    Hola Rho:

    Tengo un problema a la hora de obtener las licencias, pues despues de instalar stata y tratar de arrancarlo, me dice que no encontro ninguna licencia. He entrado en las dos paginas que tu dijiste para bajar las licencias pero no se como bajarlas, pues estan en pdf. Y luego tampoco se como copiarlas la directorio de instalacion.

    Me podrías ayudar?

    Gracias de antemano

  7. Hola Rho,
    el enlace “alternativas diferentes” para bajarme un stata para ubuntu 12.04 está roto. ¿Dónde me puedo bajar uno con el que luego pueda seguir tus instrucciones?
    Muchas gracias en todo caso.

    1. Hola Maxi, mmmm. Te diría, como corresponde, ni idea. :)

      Ahora, si me tengo que jugar la respuesta es “si”. El problema que puede surgir es que por algún motivo los paquetes se llamen de otra forma o entren en conflicto con algo que fedora tenga instalado.

      Estoy muy interesado en el tema, ya que es lo único que me está conteniendo por mudarme :)

      Si te animás a hacerlo, tirá los comandos paso por paso y luego decime cómo te fue.

      Ah! en fedora 20 puede que tengas el mismo problema que tuvo en ubuntu 1404… lo solucioné descargando debs de acá y de allá porque las dependencias no se resolvieron fácilmente.

      Te dejo mi script, obvio las dependencias las tengo en mi dropbox, pero se pueden conseguir gugleando.

      http://pastebin.com/raw.php?i=SRzHzQSg

      1. Muchas Gracias Rho, lo intentaré en Fedora, a la hora de trabajar es demasiado estar yendo a windows solo para utilizar el Stata. En caso de que logre instalarlo lo publico por acá, de igual forma si me equivoco jaja.

        Gracias por la respuesta :)

      1. Rho, comencé la instalación en fedora pero me dio el siguiente problema:

        No existe disponible ningún paquete libgtksourceview-3.0-common.
        No existe disponible ningún paquete libgtksourceview2.0-0.
        No existe disponible ningún paquete libgnomeprint2.2-0.

        Y eso que es la parte de inicio de instalación.
        Alguna recomendación ?

      2. Hola Maxi, es exactamente ese el problema. En Trusty hace exactamente lo mismo, así que me bajo las dependencias manualmente y las instalo con dpkg… para fedora creo que deberías ver si esto funciona para bajarte los paquetes:

        http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/libgtksourceview-2.0.so.0%28%29%2864bit%29

        y luego ver si, cruzando los dedos, podés instalar los rpm manualmente y no te desinstala nada. :) A ver cómo va.

        Con yum va así para llamar a los paquetes:

        su -c ‘yum install http://dondesea.net/archivo.rpm‘

        Me escribis de nuevo a ver qué paso? :D

      3. Rho, qué va. Me ha salido el error tratando de instalar libgtksourceview2.0-0.

        Traté de instalarlo manualmente y lo que me parecia es que el rpm no era compatible con fedora 20. Además en la página de libgtk solo tienen hasta fedora 11 si no mal recuerdo.

        :/ he buscado alguna otra compatibilidad y nada por el momento.

      4. hmmm…

        ok, me tiro a la pileta de nuevo. Viste que con alien se pueden transformar paquetes rpm a deb? bueno, quizás exista algo para hacer el proceso a la inversa y transformar los paquetes deb en rpm. Si se puede, entonces agarrá las dependencias desde acá http://dfiles.eu/files/gsw6de85p y pasalas a rpm…

      5. Rho, al final lo que hice fue correrlo con Wine :/, lamentablemente ese no era lo que quería. He podido conseguir 1 de las tres dependencias. Me acordé que con alien también puedo pasar de deb a rpm, pero me tiró error para libgtksourceview-3.0-common y libgnomeprint2.2-0. Por lo que no he podido instalar esas dependencias.

        Aqui está la gtksourceview2 para Fedora 20:
        http://pkgs.org/fedora-20/fedora-i386/ghc-gtksourceview2-0.12.3.1-8.fc20.i686.rpm.html

        Trataré de ver si logro instalarlo completamente sin la necesidad de Wine, por el momento solo lo que me falta es crear un acceso directo y que lo arranque como preferencia para wine jaja, pero de ahí todo bien.

        Muchas gracia Rho, que genial encontrar personas que responden sobre estos temas.

        Saludos.

      6. qué macana che… una cagada. En cuanto tenga un respiro me instalo un fedora y veo.

        Respecto a wine+stata… y si… el acceso a la memoria se va a la mierda. Capas que lo podés violentar un poco seteando la memoria desde stata estilo “oldschool”, con setmem 1024m por ejemplo. Acordate que el tamaño del dataset no puede ser superior al de la ram asignada. :)

  8. Manuel says:

    Hola!! Cuando tiro el comando me entrega esta respuesta:
    E: No se ha podido encontrar el paquete libgtksourceview2.0-0

    1. Hola Manuel, tu sistema es 32bits? si es así este tutorial no te va a servir. Tenés que buscar las mismas librerías en las carpetas de 32 bits y cambiarlas manualmente. :)

  9. RHO, lo he instalado en Elementary OS :) Todo ha salido perfecto, muchas gracias por los comentarios y por el post en general.

    Voy a ver si algún día logro realizarlo en fedora jaja
    Saludos

    1. hace un tiempo estoy con el post ese sin terminar.
      Lamentablemente no las tengo para 32 bits, tenés que buscarlas (y debo decir que a mi no me fue tan simple).
      Para 64 bits, acá van:
      http://dfiles.eu/files/gsw6de85p

      Y te recomiendo que si tu maquina corre 64 bits, que le metas una distro 64bits porque con 32 realmente lo único que vas a ganar son dolores de cabeza.
      Si tu máquina corre 32 bits por una cuestión de limitación de hardware… mmm… entonces estás complicado para correr stata te diré. ^_^

  10. Joel says:

    Ya pude instalar libgenomeprint pero ahora me quede en el comando:

    tar -xzvf docs.taz && tar -xzvf base.taz && tar -xzvf bins.taz && tar -xzvf ado.taz && chmod -R 755 .

    lo pongo en la terminal y me aparece esto:

    tar (child): docs.taz: No se puede open: No existe el archivo o el directorio
    tar (child): Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now

  11. oscar ferre says:

    Hola, sonará un poco naif, pero no consigo instalar las dependencias libgnomeprint para 64 bits (he probado con ./libgnomecups1.0-1_0.2.3-4_amd64.deb ./libgnomeprint2.2-0_2.18.8.3_amd64.deb ./libgnomeprint2.2-data_2.18.8-3_all.deb todo ello estando dentro de la carpeta que los contiene tras descomprimir con el gestor de archivadores). Siempre me atasco con los .tar.gz. ¿dónde me equivoco?

  12. oscar ferre says:

    Hola de nuevo; ya conseguí instalar libgnomecups1.0-1_0.2.3-4_amd64.deb, libgnomeprint2.2-0_2.18.8.3_amd64.deb y libgnomeprint2.2-data_2.18.8-3_ y creo que funciona el stata, pero consigo hacerlo funcionar en su versión desde línea de comandos, y no la versión de ventanas… cuando tecleo xstata desde la terminal:

    oscar@oscar-vaio:/usr/local/stata12$ xstata
    xstata: error while loading shared libraries: libgtksourceview-1.0.so.0: cannot open shared object file: No such file or directory

    1. De nada Jesus, solo te comento que en ubuntu 14.04.1 y en ubuntu 14.10 este tutorial no funciona mas debido a que movieron librerias del upstream de debian.
      La solución la tengo, pero lamentablemente no tengo mucho tiempo para hacer el post. En diciembre intentaré publicarlo. Un abrazo y me alegro que haya servido. :)

  13. Valentina says:

    trato de instalar y me tira este error :”error while loading shared libraries: libgtksourceview-1.0.so.0: cannot open shared object file: No such file or directory” Podrias ayudarme?

  14. Jorge says:

    Muy buen blog! este post es justo lo que necesitaba. Al igual que tu yo estoy haciendo mi Ph.D. pero en economía agrícola, como meta de año nuevo me propuse alejarme de Windows y comencé usando Ubuntu, a ver qué tal me va! saludos desde Alemania

  15. Ernesto says:

    Hola. muchas gracias por la ayuda. Yo estoy estancado en el paso ./stata
    de aqui se me abre en el mismo LXTerminal el stata con ms datos y licencia pero NOSE ABRE EL PROGRAMA STATA PROPIAMENTE DICHO. ES DECIR, NO SÉ COMO PROCEDER PARA ABRIR EL PROGRAMA STATA YA INSTALADO. si alguien me pudiera ayudar se lo agradeceria mucho.
    gracias!

    1. Hola Hernesto, es que el comando ./stata es para correr stata en un modo de terminal, para ahorrar recursos (VUELA). El stata normal se ejecuta con xstata. Probá de nuevo ejecutando ./xstata a ver si va bien. Si queres podés probar con ./xstata-se también, que soporta hasta 5k vars, obviamente dependiendo de la licencia que tengas. ^__^ Salú!

  16. Hola. Mira luego de un lío para instalar el paquete libgnomeprint2.2-0 pude seguir tus instrucciones para instalar el software. Ahora mi problema es que al abrirlo me pide la licencia de inmediato por lo que no me deja hacer absolutamente nada. En windows tengo instalado el programa con una licencia y no tengo el menor problema desde ya vaaarios meses, bueno, tengo entendido que el software es específico para cada plataforma, pero la licencia, no. De todas maneras, intento copiar y pegar el archivo y no tiene caso, no funciona. Estas ordenes estoy usando en la terminal

    sudo cp home/hector/Installer_stata12/STATA.LIC /usr/local/stata12

    Si me pudieras orientar al respecto, te lo agradecería mucho. Saludos y excelente aporte!

    1. Pude copiar la licencia que tenía al director, sólo me faltaba una “/”. Pero, de todas maneras no funcionó el programa arrojando el mismo problema. Creo que seguiré buscando alguna versión del software con licencia incluida… Si tuvieras un enlace por ahí sería muy bueno.

      Saludos.

  17. Maria says:

    Hola!
    Tengo un problema con la instalacion de los lib archives. En particular me dice: Couldn’t find any package by regex ‘libgnomeprint2.2-0’
    He intentado buscarlo via el Synaptic Package, pero no aparece y no se como instalarlo para poder proseguir con la instalacion del Stata12.
    Gracias por la ayuda

  18. Antony Jose says:

    No he podido hacerlo correr en este paso me sale lo siguiente :
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se ha podido localizar el paquete libgnomeprint2.2-0
    E: No se pudo encontrar ningún paquete con la expresión regular «libgnomeprint2.2-0»

Y tu? qué estás mirando? :)

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s