(Actualizado!) Gtk Theme BluMix V.02

Hola gente :)

Les comento que acabo de actualizar Blumix a la versión 0.2. Está todo encaminado, y creo que en una versión más estamos en la meta. Los cambios son:

blumix1

* Nuevo banner :)
* Nuevos elementos SVG
*Nuevo tema Gtk2
*Nuevos menues
*Redondeados, ajustes y retoques por todos lados.

Instalación

(one command install: just paste this stuff in the terminal)

cd ~ && mkdir -p .blumixinstall && cd .blumixinstall && wget https://github.com/rhoconlinux/Blumix/archive/master.zip && unzip master.zip && cd Blumix-master/ && sudo cp -a Blumix/ /usr/share/themes/ && gsettings set org.gnome.desktop.interface gtk-theme "Blumix" && gsettings set org.gnome.desktop.wm.preferences theme "Blumix" && rm -Rf ~/.blumixinstall && cd ~

Además hubo actualizaciones en Github, Deviant-art, Gnome-Look y Google+. (Esto de la publicacion en quintuplicado es un embole to-taaaal :P)

Lo que se viene:

Para la próxima versión, los cambios van a estar centrados en:
*Nuevo aspecto de nautilus
*Nuevas scrollbars Gtk3 y Gtk2
*Nuevo borde de ventana

Salú!

About these ads

20 thoughts on “(Actualizado!) Gtk Theme BluMix V.02”

  1. Gracias por este tema!

    Con gtk-3.10 da estos errores…por ejemplo, al ejecutar gnome-calculator :

    (gcalctool:32002): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1798:4: Junk at end of value

    (gcalctool:32002): Gtk-WARNING **: Theme parsing error: gnome-applications.css:94:19: Not using units is deprecated. Assuming ‘px’.

    (gcalctool:32002): Gtk-WARNING **: Theme parsing error: gnome-applications.css:99:19: Not using units is deprecated. Assuming ‘px’.

    (gcalctool:32002): Gtk-CRITICAL **: _gtk_css_section_to_string: assertion ‘section != NULL’ failed

    (gcalctool:32002): Gtk-WARNING **: Theme parsing error: (null): Expected a boolean value

    1. Gracias! : )
      Muchos de los errores son inocuos (no hacen a la performance o estética del tema ya que son entradas que avisan que los valores son “deprecated” para las nuevas versiones de gtk y que ahora tengo que especificar que son pixeles y no unidades… pero nah, no pasa nah jeje), para la próxima versión los arreglo ;)

    1. Hmmm… tanto en qtcurve como en bespin requeriría una *reescritura completa*, no un port.
      El problema en ambos es que los temas se hacen con GUI (interfaz gráfica) y el código no tiene nada que ver con la estructura gtk.
      No prometo nada, quizás lo haga, pero me tienen que venir muuuchas ganas :P
      Obviamente, si te animás te ayudo a hacer el clon :)

  2. Fixed your install script. Has some minor syntax issues:

    cd ~ && mkdir -p .blumixinstall && cd .blumixinstall && unzip && wget master.zip https://github.com/rhoconlinux/Blumix/archive/master.zip Blumix-master && cd / && sudo cp-a Blumix / / usr / share / themes / gsettings September org.gnome.desktop.interface && gtk-theme “Blumix” && org.gnome.desktop.wm.preferences September gsettings theme “Blumix” && rm-Rf ~ /.blumixinstall && cd ~

  3. Me encanta el tema lo malo que me sale la tipografia blanca y no se distigue en las ventanas por ejemplo los nombres de los documentos…sale todo blanco y como el fondo es claro no se distingue y el wingpanel me sale con fondo negro ese si me gusta jajajajaja parece el gnome shell ayudame porfavor

      1. Hola Estaban!
        Seguro, para instalarlo mediante PPA (te avisa cuando hay actualizaciones y las instala con sudo apt-get upgrade), es así:
        sudo add-apt-repository ppa:numix/ppa && sudo apt-get update && sudo apt-get install -y numix-icon-theme-circle

        Ahora, si usas algún ubuntu viejo, o simplemente no querés agregar ppas, existe una alternativa manual, pero vas a tener que repetir este proceso cada vez que salga una nueva versión, porque el sistema no te va a avisar que el paquete se actualizó. Para la instalación manual, copiá y pegá esto:

        cd ~ && wget https://launchpad.net/~numix/+archive/ppa/+files/numix-icon-theme-circle_0.2%2B201312072007%7E60%7Eubuntu14.04.1_all.deb -O numix-circle.deb && sudo dpkg -i numix-circle.deb && rm numix-circle.deb

        Saludos!

    1. Hola Sebastián, en corta: NO. :)
      Luna es muy viejo y usa librerías muy viejas, del 2012.
      Este tema está pensado para gtk 3.10 o superior mientras que en luna tienen gtk 3.04…
      En isis va a funcionar perfecto. :)

Y tu? qué estás mirando? :)

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s